PHP „Zgłupiało”

PHP „Zgłupiało”

Na moim serwerze z linux debian 5.0 skrypt ten jest wykonywany prawidłowo:

Kod PHP:


#!/usr/bin/php5
function zabezpiecz($zmienna){
    
$zmienna=stripslashes($zmienna);
    
$zmienna=htmlspecialchars($zmienna);
    return 
$zmienna;
}

$_SERVER  array_map('zabezpiecz'$_SERVER); 




A na nowo zainstalowanym serwerze z linux debian 6.0 (również te same php itp.) wywala taki błąd:

Cytat:

PHP Warning: stripslashes() expects parameter 1 to be string, array given in …


Sam błąd wiem co oznacza, tylko pytanie dlaczego tam działa, a tutaj nie? :O

PS. Konfiguracja PHP taka sama tu i tam (domyślna jaka została dodana przy instalacji).

Comments are closed.